20201104 cisco EIGRP (一)

課堂資料

Enhanced Interior Gateway Routing Protocol ( EIGRP ) 增強型內部網關路由協定:

EIGRP 設定:

CSICO EIGRP

Enhanced Interior Gateway Routing Protocol
  • 採用 DUAL Algorithmshow ip route
  • 高級 ( Advanced ) 的 DV ( Distance Vector ) or Mixed
  • IP header protocol:88
協定
protocol 值
ICMP ( 網際網路控制訊息協定 )
1
TCP ( 傳輸控制協定 )
6
UDP ( 用戶資料報協定 )
17
EIGRP ( 混合型路由協定 )
88
  • VLSM ( Variable Length Subnet Mask ) and CIDR ( Classless Inter Domain Routing )
  • AD ( 動態距離:Administration Distance ) = 90
協定
AD值
Static Route ( 靜態路由 )
1
EIGRP ( 混合型路由協定 )
90
OSPF ( 鏈路狀態路由協定 )
110
RIP ( 路由資訊協定 )
120
  • metrics ( 指標 ):BW ( 帶寬:BandWidth )、Delay ( 延時 )、Load ( 加載 )、Reliabily ( 可靠性 )、MTU ( 最大傳輸單元:Maximum Transmission Unit )
  • trigger update:224.0.0.10 (增量更新,可靠更新:Reliabily update)
    • RIPv1:255.255.255.255
    • RIPv2:224.0.0.9

補充

封包類型
作用
Hello
用於建立和維持 Neighborhood
Update
用於傳送路由條目
Ack
用於實現可靠傳輸
Query
用於路由丟失時,向鄰居發送路由請求
Reply
收到路由請求,給予回覆
EIGRP有三張表:
  1. 1.
    鄰居表 ( neighbor table )
  2. 2.
    拓樸表 ( protocol table )
  3. 3.
    路由表 ( routing table )

課堂練習

Neighbor

IP 設定

R1
R2
R3
conf t
hostname R1
do writ
int e0/0
ip addr 192.168.12.1 255.255.255.0
no shut
conf t
hostname R2
do writ
int e0/0
ip addr 192.168.12.2 255.255.255.0
no shut
exit
int e0/1
ip addr 192.168.23.2 255.255.255.0
no shut
conf t
hostname R3
do writ
int e0/0
ip addr 192.168.23.3 255.255.255.0
no shut

Route 設定

使用router eigrp [AS No.]進入EIGRP設定,在同一個 AS內的EIGRP router,所有的AS Number必須相同。
R1
R2
R3
router eigrp [AS No.]
auto-summary
network 192.168.12.0 0.0.0.255
router eigrp [AS No.]
auto-summary
network 192.168.12.0 0.0.0.255
network 192.168.23.0 0.0.0.255
router eigrp [AS No.]
auto-summary
network 192.168.23.0 0.0.0.255
do sh ip eigrp nei
do sh ip eigrp topology
do sh ip ro eigrp
R1
R2
R3
預設情況下,Router 之間是利用 Multicast 溝通的。
如果網路不支援 Multicast 或因某些原因 Multicast 無法順利傳送,Router 就無法成為 Neighbor。
遇到這些情況,我們使用Neighbor指令利用Unicast去傳送EIGRP封包。
R1
R2
neighbor 192.168.12.2 e0/0
neighbor 192.168.12.1 e0/1
do sh ip eigrp neighbors
確認有無順利建立Neighbor,可以用show ip eigrp nieghbors指令

Holdtime

EIGRP 有兩個 Timer,分別是 Hello Timer 及 Hold Timer。
Hello 預設值為 5秒、Hold 預設值為 15秒,也就是說 EIGRP Router 會隔 5秒傳送 Hello Message,如果收到就會維持 Neighbor 關係,反之,一旦超過15秒未收到,則會中斷 Neighbor 關係。
所以Hold Timer會從15秒開始倒數,直到收到Hello後重新計數倒數15秒。
Hello Timer 及 Hold Timer 是可以在interface下更改。
R2
int e0/0
ip hello-interval eigrp ?
ip hello-interval eigrp [AS No.] ?
ip hello-interval eigrp [AS No.] 10
ip hold-time eigrp ?
ip hold-time eigrp [AS No.] ?
ip hold-time eigrp [AS No.] 30
^z
切記,兩隻成為 Neighbor 也要更改。
R2
clear ip eigrp [AS No.] nei
sh ip eigrp nei

Authentication

在 EIGRP Neighbor 的 interface 之間設定密碼,這樣可以避免有 Router 假扮成 Neighbor 來偷取 Router 資訊。
conf t
key chain MyChain
key 1
key-string MyPassword
exit
exit
R1
R2
在interface 設定 Key Chain 和 MD5 encryption
R1
R2
int e0/0
ip authentication key-chain eigrp [AS No.] MyChain
ip authentication mode eigrp [AS No.] md5
int e0/1
ip authentication key-chain eigrp [AS No.] MyChain
ip authentication mode eigrp [AS No.] md5
sh ip eigrp int detail 可以查看Authentication 資訊
do sh ip eigrp int detail
R1
R2

期中練習

01.
02.
03.

題目:

結果:

R1

int e0/0
ip add 12.1.1.1 255.255.255.0
no shut
int e0/1
ip add 45.1.1.1 255.255.255.0
no shut
int e0/2
ip add 192.168.1.1 255.255.255.0
no shut
ip route 192.168.2.0 255.255.255.0 e0/0 12.1.1.2
ip route 192.168.2.0 255.255.255.0 e0/1 45.1.1.3 10

R2

int e0/0
ip add 12.1.1.2 255.255.255.0
no shut
int e0/1
ip add 23.1.1.2 255.255.255.0
no shut
int e0/2
ip add 192.168.2.1 255.255.255.0
no shut
ip route 192.168.1.0 255.255.255.0 e0/0 12.1.1.1 10
ip route 192.168.1.0 255.255.255.0 e0/1 23.1.1.4

R3

int e0/0
ip add 34.1.1.3 255.255.255.0
no shut
int e0/1
ip add 45.1.1.3 255.255.255.0
no shut
ip route 192.168.1.0 255.255.255.0 e0/1 45.1.1.1

R4

int e0/0
ip add 34.1.1.4 255.255.255.0
no shut
int e0/1
ip add 23.1.1.4 255.255.255.0
no shut
ip route 192.168.1.0 255.255.255.0 e0/0 34.1.1.3

VPC1

ip 192.168.1.2 255.255.0.0

VPC2

ip 192.168.2.2 255.255.0.0

題目:

結果:

R1

hostname R1
do writ
int e0/0
ip addr 12.1.1.1 255.255.255.0
no shut
int e0/1
ip addr 192.168.1.1 255.255.255.0
no shut
exit
ip dhcp pool DHCP
network 192.168.1.0 /24
default-router 192.168.1.1
dns-server 8.8.8.8

VPC 1

ip dhcp
ping 192.168.2.2

R2

hostname R2
do writ
int e0/0
ip addr 12.1.1.2 255.255.255.0
no shut
int e0/1
ip addr 192.168.2.1 255.255.255.0
no shut
exit
ip dhcp pool DHCP2
network 192.168.2.0 /24
default-router 192.168.2.1
dns-server 8.8.8.8

VPC 2

ip dhcp
ping 192.168.1.2

題目:

結果:

R1

int e0/0
ip addr 12.1.1.1 255.255.255.0
no shut
int e0/1
ip addr 45.1.1.1 255.255.255.0
no shut
int e0/2
ip addr 192.168.1.1 255.255.255.0
no shut
int lo 0
ip addr 1.1.1.1 255.255.255.255
no shut
exit
router rip
ver 2
no auto-summary
network 12.1.1.0
network 45.1.1.0
network 1.1.1.0
network 192.168.1.0
do sh run

R2

int e0/0
ip addr 12.1.1.2 255.255.255.0
no shut
int e0/1
ip addr 23.1.1.2 255.255.255.0
no shut
int lo 0
ip addr 2.2.2.2 255.255.255.255
no shut
exit
router rip
ver 2
no auto-summary
network 12.1.1.0
network 23.1.1.0
network 2.2.2.0
do sh run

R3

int e0/0
ip addr 34.1.1.3 255.255.255.0
no shut
int e0/1
ip addr 45.1.1.3 255.255.255.0
no shut
int lo 0
ip addr 3.3.3.3 255.255.255.255
no shut
exit
router rip
ver 2
no auto-summary
network 34.1.1.0
network 45.1.1.0
network 3.3.3.0
do sh run

R4

int e0/0
ip addr 34.1.1.4 255.255.255.0
no shut
int e0/1
ip addr 23.1.1.4 255.255.255.0
no shut
int e0/2
ip addr 192.168.2.1 255.255.255.0
no shut
int lo 0
ip addr 4.4.4.4 255.255.255.255
no shut
exit
router rip
ver 2
no auto-summary
network 23.1.1.0
network 34.1.1.0
network 4.4.4.0
network 192.168.2.0
do sh run

VPC 1

ip 192.168.1.2 255.255.0.0
ping 192.168.2.2

VPC 2

ip 192.168.2.2 255.255.0.0
ping 192.168.1.2